2018年10月
  1 2 3 4 5 6
7 8 9 10 11 12 13
14 15 16 17 18 19 20
21 22 23 24 25 26 27
28 29 30 31      
無料ブログはココログ

アマゾン

« 今日は、「アイ・イン・ザ・スカイ」でした。 | トップページ | 今日は、「スーサイド・スクワッド」でした。 »

2018年8月 9日 (木)

pythonで人工知能やって見る? 環境構築

2018/8/9

今流行りの人工知能、ディープラーニングをかじってみようと

家のMacに環境を作るためにまず、Homebrewをインストール

続いてPython3をインストール

とりあえず、ここのまでは、正常にインスートルできました。

whichでの確認もできました。ちなみにバージョンは3.7.0でした。

次にオススメのライブラリを入れる

$ pip3 install numpy  # 線形代数
$ pip3 install scipy  # 数式処理
$ pip3 install matplotlib   # 描画 
$ pip3 install pandas  # データ操作

いよいよ機械学習用のライブラリ

$ pip3 install scikit-learn
$ pip3 install chainer

pythonの実行環境

$ pip3 install jupyter

今日は、ここまで。

2018/8/10

今日は、インストール記事でオススメのエディタ ATOMをインストール、このエディタ かなり高機能らしくてブロジェト管理しがら、自身のターミナルウインドウを持っててそちらで実行状況を観れるらしい、とりあえずATOMのターミナルでpython3を起動してみました。

iMac27:~ nobu$ python3

Python 3.7.0 (default, Jul 23 2018, 20:24:19)

[Clang 9.0.0 (clang-900.0.39.2)] on darwin

Type "help", "copyright", "credits" or "license" for more information.

>>>

無事、python3起動成功。

とりあえず、環境はできたみたい、ただしpython3にしろATOMにしろ使い方が分かっていない、これからおいおい使って見るかな。まぁやる気が萎えなければ....

今日は、ここまで。

2018/8/20

その後 CV2をインストールして、次にtensolflowをすインストールしようとすると

  Could not find a version that satisfies the requirement tensorflow (from versions: )

 

No matching distribution found for tensorflow

って、言われ入れられない。無視して、テスト的な機械学習をやってみるが上手くいかない。

しばし、悩んだ後、pythonのバージョンが3.7.0である。web上の記事ではほぼ3.6である。

バージョンが新しすぎて、ダメなんじゃって事に思い至り、pythonのばーじょん管理をしてくれるというpyenvをインストールしてみる。

brew install pyenv

なんかpythonやanacondaやら色々なものの色んなバージョンがインストールされたっぽい。

で、

pyenv rehash

pyenv global TensorFlow

python --version

Python 2.7.10

ってなって、2.7.10になっちった。

pyenv local 3.6.0

python --version

 

Python 2.7.10

あれ、3.6にならない。でまたまたwebで探して。
export PATH="$HOME/.pyenv/shims:$PATH"
source ~/.bash_profile

ってするといいよって記事を見つけ、やってみると

python --version

 

Python 3.6.0

見事に3.6になりました。
pyenvがインストール先のパスを知らなかったのかな?
まぁいいか、しかし、webに感謝です。
で、pip3 install --upgrade tensorflow とすると
見事インストールできました。
で、import tensorflow
と確認するとインストールが確認されました。
とりあえず、メデタシめでたし。
今日はここまで、
で、試しに機械学習って思ったけど、エラー。
よく考えると、Python3.6.0で、ライブラリを再度インストールする必要に気づき
最初からインストール。
これで、環境ができたはずだ!!
2018/08/25
って、思ったけれどpyenvでlocalで3.6.0を指定しているのにpythonを起動すると2.7.10が立ち上がる。
で、「pythonのバージョンが切り替わらない 」などで検索すると色々記事が出て来ます。
その記事を参考にパスを直して、無事3.60が起動するようになりました。
あとわけもわからず、anacondaなどをインストール。

とりあえず、環境はできたのか?
chanerがなぜかイマイチだが。

« 今日は、「アイ・イン・ザ・スカイ」でした。 | トップページ | 今日は、「スーサイド・スクワッド」でした。 »

パソコン・インターネット」カテゴリの記事

コメント

コメントを書く

(ウェブ上には掲載しません)

トラックバック

この記事のトラックバックURL:
http://app.cocolog-nifty.com/t/trackback/574424/67038620

この記事へのトラックバック一覧です: pythonで人工知能やって見る? 環境構築:

« 今日は、「アイ・イン・ザ・スカイ」でした。 | トップページ | 今日は、「スーサイド・スクワッド」でした。 »